Cadastro de novo usuário

Mensagem
Autor
flavio
Mensagens: 7
Registrado em: 15 Nov 2007, 22:15

Cadastro de novo usuário

#1 Mensagem por flavio » 23 Nov 2007, 00:50

Tenho problemas em eviar e-mail quando um usuário é cadastrado, onde configuro?
Aparece uma mensagem conforme o email de confirmação será enviado, e logo depois um erro dizendo q a mensagem nao pode ser enviada e mandando contatar o administrador do sistema.

Your moodle configuration is currently not able to send email. This is likely due to problems with your SMTP settings in the configuration file of your site. Please tell the administrator of your system to reconfigure this file, and try again.

o problema eh q o administrator sou eu em um servidor local...

obrigado



Avatar do usuário
alex
Site Admin
Mensagens: 44
Registrado em: 27 Out 2007, 18:14
Localização: Brasília
Contato:

Re: Cadastro de novo usuário

#2 Mensagem por alex » 24 Nov 2007, 21:33

Flavio, voce usa linux? Veja se o serviço smtp do servidor que hospeda o moodle está ativado.



NERI
Mensagens: 13
Registrado em: 28 Out 2007, 22:30

Re: Cadastro de novo usuário

#3 Mensagem por NERI » 17 Dez 2007, 22:24

Estou com problema semelhante e já postei na Comunidade Moodle, mas ninguém pode me ajudar. O problema que estou enfrentando é este: ao cadastrar um novo usuário, recebo a seguinte mensagem:

ERROR: SMTP Error: Could not connect to SMTP host.

Tried to send you an email but failed!

Será se alguém poderia me ajudar?

Desde já, sou muito agradecido.

Rivaldo Neri.


Prof. Rivaldo Neri.

"Em CRISTO encontrei a verdadeira paz". (Leia João 14.27)

flavio
Mensagens: 7
Registrado em: 15 Nov 2007, 22:15

Re: Cadastro de novo usuário

#4 Mensagem por flavio » 22 Dez 2007, 21:51

ERROR: Could not instantiate mail function.


Tried to send you an email but failed!

Outras informações sobre este erro


não, eu não uso linux, uso Windows Xp professional e já não sei mais o que fazer, conversei com o cara que implantou o moodle na UEA e ele me disse que teve o mesmo problema, eu fui la pra confirmar no site, me cadastrei e constatei que no moodle ta UEA há o mesmo proplema do meu servidor pessoal.
Mais alguém pode ajudar?

Obrigado



flavio
Mensagens: 7
Registrado em: 15 Nov 2007, 22:15

Re: Cadastro de novo usuário

#5 Mensagem por flavio » 22 Dez 2007, 21:53

Só mais uma coisinha, o servidor que uso é o apache, pois como o tutorial de instalação aconselhava, eu instalei o vertrigo.
Obrigado



Avatar do usuário
alex
Site Admin
Mensagens: 44
Registrado em: 27 Out 2007, 18:14
Localização: Brasília
Contato:

Re: Cadastro de novo usuário

#6 Mensagem por alex » 24 Dez 2007, 08:37

O problema é simples de resolver! É necessário especificar o endereço do servidor de smtp. O smtp é o servidor que envia mensagens de e-mail. Neste caso é necessário saber com o seu provedor, qual é o endereço do servidor de smtp que você poderá usar. O Linux já vem com um servidor de envio de e-mails dentro dele. Se estiver rodando no linux, basta especificar "localhost" no endereço. Se for linux e não tiver um serviço de smtp instalado, tem que especificar um endereço externo, que é o ideal. Com o Cd de instalação do XP ou 2000, é possível instalar um serviço SMTP no próprio computador que está rodando o vertrigo, por exemplo, mas o ideal mesmo é usar um smtp externo (do provedor), pois nem todos os provedores recebem e-mail vindo de computadores caseiro, apenas de servidores grandes. Acho que o uol tem essa restrição.

Abraços,
Alex



flavio
Mensagens: 7
Registrado em: 15 Nov 2007, 22:15

Re: Cadastro de novo usuário

#7 Mensagem por flavio » 27 Dez 2007, 23:52

arquivo php.ini

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

seria aqui o lugar onde eu devo especificar o novo endereço?
uso conexão velox com provedor oi. Tem idéia de como seria a configuração smtp?

obrigado



Avatar do usuário
alex
Site Admin
Mensagens: 44
Registrado em: 27 Out 2007, 18:14
Localização: Brasília
Contato:

Re: Cadastro de novo usuário

#8 Mensagem por alex » 28 Dez 2007, 10:52

Não, não precisa mexer no php.ini.

Entre no Moodle no endereço:

http://www.[seu site do moodle]/admin/settings.php?section=mail

Para preencher o endereço do servidor smtp, ligue pro provedor (velox no seu caso). Entre neste site e configure. É só dar OK e pronto :)

Alex



flavio
Mensagens: 7
Registrado em: 15 Nov 2007, 22:15

Re: Cadastro de novo usuário

#9 Mensagem por flavio » 28 Dez 2007, 15:43

Sucesso, em partes. liguei pra oi e fiquei sabendo que o smtp é smtp.oi.com.br, configurei e agora pelo menos não recebo mensagens de erro.
Assim que confirmo o cadastro, aparece a seguinte mensagem:

An email should have been sent to your address at flavio...@gmail.com

It contains easy instructions to complete your registration.

If you continue to have difficulty, contact the site administrator.

O problema é que o e-mail não chegou à minha caixa de entrada.
Mais alguma dica?

e mais uma vez obrigado.



Avatar do usuário
alex
Site Admin
Mensagens: 44
Registrado em: 27 Out 2007, 18:14
Localização: Brasília
Contato:

Re: Cadastro de novo usuário

#10 Mensagem por alex » 28 Dez 2007, 23:42

Então pode ser que esteja entrando direto para a pasta de junk mail do gmail. Se não deu erro, pouca chance do e-mail não estar saindo. Faça um teste com outros e-mails e veja com a oi se o smtp não precisa de autenticação...
Abraços



Responder